Quantcast

ERROR: stream classdesc serialVersionUID = 5166066541265170937, local class serialVersionUID = 8808844570772337501

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ERROR: stream classdesc serialVersionUID = 5166066541265170937, local class serialVersionUID = 8808844570772337501

gbelin
Hi there,

I am trying load the example package mortgages with

KnowledgeAgent kagent = KnowledgeAgentFactory.newKnowledgeAgent( "MortgageAgent" );
kagent.applyChangeSet( ResourceFactory.newUrlResource( "http://localhost:8080/guvnor-webapp/org.drools.guvnor.Guvnor/package/mortgages/LATEST/ChangeSet.xml" ) );
KnowledgeBase kbase = kagent.getKnowledgeBase();


the execution of the "applyChangeSet" produces the error:


java.lang.RuntimeException: KnowledgeAgent exception while trying to deserialize KnowledgeDefinitionsPackage  
        at org.drools.agent.impl.KnowledgeAgentImpl.createPackageFromResource(KnowledgeAgentImpl.java:732)
        at org.drools.agent.impl.KnowledgeAgentImpl.addResourcesToKnowledgeBase(KnowledgeAgentImpl.java:965)
        at org.drools.agent.impl.KnowledgeAgentImpl.rebuildResources(KnowledgeAgentImpl.java:774)
        at org.drools.agent.impl.KnowledgeAgentImpl.buildKnowledgeBase(KnowledgeAgentImpl.java:646)
        at org.drools.agent.impl.KnowledgeAgentImpl.applyChangeSet(KnowledgeAgentImpl.java:190)
        at org.drools.agent.impl.KnowledgeAgentImpl.applyChangeSet(KnowledgeAgentImpl.java:172)
        at com.sample.DroolsTest.main(DroolsTest.java:42)
Caused by: java.io.InvalidClassException: org.drools.rule.MVELDialectRuntimeData; local class incompatible: stream classdesc serialVersionUID = 5166066541265170937, local class serialVersionUID = 8808844570772337501
        at java.io.ObjectStreamClass.initNonProxy(Unknown Source)





I suppose it is a problem with different versions of any library, but I do not know which one, I think I have the latest version of all libraries ...

My development environment:

Server:
  Apache Tomcat  6.0.26
  Guvnor server Version 5.2.0.Final

Client:
  Eclipse 3.5 Galileo
  Java jre6
  mvel2.jar version 2.0.19
  drools-api.jar Bundle-Version: 5.2.0.SNAPSHOT
  drools-core.jar Bundle-Version: 5.2.0.SNAPSHOT


Thanks in advance.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [rules-users] ERROR: stream classdesc serialVersionUID = 5166066541265170937, local class serialVersionUID = 8808844570772337501

laune
Don't use those SNAPSHOT jars - get the 5.2.0.FINAL ones.
-W


On 18 July 2011 11:11, gbelin <[hidden email]> wrote:
Hi there,

I am trying load the example package mortgages with
/
KnowledgeAgent kagent = KnowledgeAgentFactory.newKnowledgeAgent(
"MortgageAgent" );
kagent.applyChangeSet( ResourceFactory.newUrlResource(
"http://localhost:8080/guvnor-webapp/org.drools.guvnor.Guvnor/package/mortgages/LATEST/ChangeSet.xml"
) );
KnowledgeBase kbase = kagent.getKnowledgeBase();/

the execution of the "applyChangeSet" produces the error:


/java.lang.RuntimeException: KnowledgeAgent exception while trying to
deserialize KnowledgeDefinitionsPackage
       at
org.drools.agent.impl.KnowledgeAgentImpl.createPackageFromResource(KnowledgeAgentImpl.java:732)
       at
org.drools.agent.impl.KnowledgeAgentImpl.addResourcesToKnowledgeBase(KnowledgeAgentImpl.java:965)
       at
org.drools.agent.impl.KnowledgeAgentImpl.rebuildResources(KnowledgeAgentImpl.java:774)
       at
org.drools.agent.impl.KnowledgeAgentImpl.buildKnowledgeBase(KnowledgeAgentImpl.java:646)
       at
org.drools.agent.impl.KnowledgeAgentImpl.applyChangeSet(KnowledgeAgentImpl.java:190)
       at
org.drools.agent.impl.KnowledgeAgentImpl.applyChangeSet(KnowledgeAgentImpl.java:172)
       at com.sample.DroolsTest.main(DroolsTest.java:42)
Caused by: java.io.InvalidClassException:
org.drools.rule.MVELDialectRuntimeData; local class incompatible: stream
classdesc serialVersionUID = 5166066541265170937, local class
serialVersionUID = 8808844570772337501
       at java.io.ObjectStreamClass.initNonProxy(Unknown Source)


/


I suppose it is a problem with different versions of any library, but I do
not know which one, I think I have the latest version of all libraries ...

My development environment:

Server:
 Apache Tomcat  6.0.26
 Guvnor server Version 5.2.0.Final

Client:
 Eclipse 3.5 Galileo
 Java jre6
 mvel2.jar version 2.0.19
 drools-api.jar Bundle-Version: 5.2.0.SNAPSHOT
 drools-core.jar Bundle-Version: 5.2.0.SNAPSHOT


Thanks in advance.




--
View this message in context: http://drools.46999.n3.nabble.com/ERROR-stream-classdesc-serialVersionUID-5166066541265170937-local-class-serialVersionUID-880884457071-tp3178597p3178597.html
Sent from the Drools: User forum mailing list archive at Nabble.com.
_______________________________________________
rules-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/rules-users


_______________________________________________
rules-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/rules-users
Loading...